Android アプリのバージョン情報記述方法について

  • このエントリーをはてなブックマークに追加

Android Developer Console に新しく更新したアプリをアップロードしたら以下のエラーが表示された。

バージョン コード 1 の APK が既に存在するため、別のバージョン コードを使用する必要があります。

Eclipse を使っていたころは、AndroidManifest.xml に versionCode と versionName を記述していたが、Android Studio から記述先が変わったのか、エラーになってしまう。

その代わりに build.gradle へ記述したらアップロードできるようになった。

いつから変わったのだろうか!?

スポンサーリンク
  • このエントリーをはてなブックマークに追加